Description

EpicDispensers brings in a new way for your players to make farms, grinders, and much more. Players can simply decide the action of the dispenser by placing a sword into the dispensers inventory. No redstone attached. Expect to see some interesting farms on your server! Includes StackMob Support.


Installation

Just like many other plugins, all you need to do is drag and drop EpicDispensers jar file into your plugins directory.

Features

  • Upgrades - Able to upgrade your dispensers allowing them to boost up in stats
  • Auto-Kill - have your dispensers auto kill mobs for you
  • Upgraded dispensers shoot arrows - These dispensers shoot arrows in a 360-degree area with no redstone

Plugin Features How to's

  1. Upgrading: You are able to upgrade your dispensers by right-clicking the dispenser and you have a choice using Exp. or Eco-Money. This will allow your dispenser to increase its range and other features that Epic Dispenser allows it to do. You are also able to change the settings for the hoppers on what each level will give upon each level up.
  2. Auto-Killing: You are able to set up your dispenser to auto kill by providing it with a sword and it will kill any mob that comes in its range for you and stores the drops in the dispensers own inventory.
  3. Arrow Shooting: You are able to upgrade your dispenser enough to allow it to shoot arrows for you so it can shoot any mobs that come in its range but after you supply it with arrows to shoot. Also, drops will be stored in the dispensers own inventory.

Commands

CommandPermissionsDescriptionSyntax
ED Help(Default)Displays information about EpicDispensers./ed help
ED Reload(OP)Reloads the configuration and language files./ed reload
ED Give (OP)Gives the <player> a specific level and amount of dispensers/ed <player> <level> <amount>

Permissions

PermissionDescription
EpicDispensers.ViewLets the player view the EpicDispensers GUI
EpicDispensers.GivePermission to use the '/ed give' command.
EpicDispensers.Upgrade.XPAllows the player to upgrade the dispensers level with XP.
EpicDispensers.Upgrade.ECOAllows the player to upgrade the dispensers level with the economy.
EpicDispensers.AdminRequired for reloading the configurations.
EpicDispensers.OverviewPermissions to view the upgrade menu.
Config
#       ______      _      ____  _                                          
#      / ____/___  (_)____/ __ \(_)________  ___  ____  ________  __________
#     / __/ / __ \/ / ___/ / / / / ___/ __ \/ _ \/ __ \/ ___/ _ \/ ___/ ___/
#    / /___/ /_/ / / /__/ /_/ / (__  ) /_/ /  __/ / / (__  )  __/ /  (__  ) 
#   /_____/ .___/_/\___/_____/_/____/ .___/\___/_/ /_/____/\___/_/  /____/  
#        /_/                       /_/                                      
#
#                         Created by Songoda
#
#
# The configuration version, don't change unless you know what you're doing.
version: "2.0.3"

# Print additional information to console.
# Developers of Songoda may ask you to enable this when reporting issues.
debug: false

# Removes color from being displayed in EpicDispenser messages for those systems who can't view color.
remove-console-color: false

# The dispenser configuration section.
dispensers:
    # How often the dispensers are updated.
    tick: 30
    # Should the dispensers have an animation?
    animations: true
    bow-particle: "SWEEP_ATTACK"
    sword-particle: "SWEEP_ATTACK"
    # Should the dispensers do durability on items.
    item-durability: true

# This will disable the message stating who gave the user a Dispenser.
disable-give-message: false

# If on older versions than 1.13, you will probably be getting errors about wrong material enums.
# You can lookup proper enum names for your server to fix, or just set this to true and let EpicDispensers decide.
# We really recommend you take the time to configure the Material options below.
# 1.9-1.12 are the enums in the "quotes" here: https://pastebin.com/Fe65HZnN
# 1.8 can be found here https://github.com/Attano/Spigot-1.8/blob/master/org/bukkit/Material.java
disable-wrong-enum-warning: false

# If a normal dispenser is broken, should it be turned into an EpicDispenser?
breaking-normal-makes: false

# The economy configuration section.
economy:
    economy-format: "#,###.00"

# The permissions configuration section.
permissions:
    # The permission for users to upgrade using their Experience.
    upgrade-xp: "epicdispensers.upgrade.xp"
    # The permission for users to upgrade using their Economy aka Money.
    upgrade-economy: "epicdispensers.upgrade.economy"
    # Permission to use the '/ed give' command.
    give: "epicdispensers.give"
    # Required for reloading the configurations.
    admin: "epicdispensers.admin"
    # Permissions to view the upgrade menu.
    overview: "epicdispensers.overview"

menus:
    glass-1:
        # If not using 1.13 set the Material to STAINED_GLASS_PANE
        material: "GRAY_STAINED_GLASS_PANE"
        rainbow: false
        name: "&r"
        # color is used on versions lower than 1.13
        color: 7
    glass-2:
        # If not using 1.13 set the Material to STAINED_GLASS_PANE
        material: "BLUE_STAINED_GLASS_PANE"
        rainbow: false
        name: "&r"
        # color is used on versions lower than 1.13
        color: 11
    glass-3:
        # If not using 1.13 set the Material to STAINED_GLASS_PANE
        material: "LIGHT_BLUE_STAINED_GLASS_PANE"
        rainbow: false
        name: "&r"
        # color is used on versions lower than 1.13
        color: 3
    upgrade-economy:
        material: "SUNFLOWER"
        # color is used on versions lower than 1.13
        color: 3
    upgrade-xp:
        material: "EXPERIENCE_BOTTLE"
        # color is used on versions lower than 1.13
        color: 3
    # The item to replace the above upgrades when the option is disabled.
    cant-upgrade-xp:
        material: "REDSTONE_BLOCK"
        name: "&cYou cannot upgrade to next level with experience."
        # color is used on versions lower than 1.13
        color: 3
    cant-upgrade-economy:
        material: "REDSTONE_BLOCK"
        name: "&cYou cannot upgrade to next level with money."
        # color is used on versions lower than 1.13
        color: 3


  • No labels